Back to overview
Power Outage
May 09 at 10:39am BST
Affected services
Plex
Ombi
Resolved
May 09 at 10:39am BST
Due to some Muppet driving into an electrical distribution board down the road, power is out so everything is #OFFLINE.
Update expected at 20:00 UTC
Affected services